Wednesday, 5 March 2014

Ajax TruClient does not support certain plug-ins

Problem detail:   We currently have VU Gen 11.0. When we try to record an application with a flash plug-in we get a message to download the plug-in. If we record using click n script or Web HTML it works fine.

Problem Solution:

We resolved the issue with the following steps. If you need to propagate this information across the team....

Follow these steps to get this working:

1. Download the Flash 10 files from the following URL:

http://fpdownload.macromedia.com/get/flashplayer/xpi/current/flashplayer-win.xpi

2. Rename the file you just downloaded (called flashplayer-win.xpi) to flashplayer-win.zip

3. Extract the files in the zip file archive

4. Copy the files flashplayer.xpt and NPSWF32.dll to the Firefox plugin directory that was created during the LR 11 install. For me, that location was here:

C:\Program Files\HP\LoadRunner\bin\firefox\plugins

5. Restart Firefox for the Flash 10 component to integrate into Firefox.

 

2 comments: