Tuesday, 18 February 2014

IE crashed during recording

Problem Details:- When record the AUT with Vugen 9.52, IE crashed during recording.

Problem Solution:-  1) LR9.52 on Windows 2003 SP2,
IE version is: 7.0.6000.17096

2) IE crashed during recording.
This issue occurs for a specific web site .
It does NOT occur if the customer record another website.


3)uploaded webex recording video to :
ftp://SC045b2b:F2cr!TN4@ftp.usa.hp.com/ie_crash.wrf

In the webex
a) it is OK to record the URL http://stg-ccm.health.ge.com
b) It is NG to record another website: http://stg2-businessobjects.health.ge.com,
Protocl: Web
IE crashed during recording.

In system event log, it left error:

"Faulting application iexplore.exe, veresion 7.0.6000.17096, faulting module msvcr80.dll, version 8.0.50727.3079, fault address 0x00012331
"
c) It is also NG to record with Ajax protocl : http://stg2-businessobjects.health.ge.com,
IE crashed during recording, same error can be seen in system event log,


4) Suggested custome to record the application with earlier record engine, but it doesn't help.

Tools->Recording Option->Advanced
Check "Record script using earlier record engine".

5) Try to register dll file msvcr80.dll , but it doesn't help.
in command prompt , execute:
cd C:\WINDOWS\WinSxS\x86_Microsoft.VC80.CRT_1fc8b3b9a1e18e3b_8.0.50727.3079_x-ww_b811a94e
regsvr32 msvcr80.dll/ie_crash.wrf
The last information that I have about your issue is that a problem with msvcr80.dll.

Well this is caused by a bug in Microsoft's redistributable DLL, MSVCR80.dll.

In this situation, the problematic system did not have Visual Studio 2005 or SQL Server 2008, but did have the Visual Studio remote debugger installed.

Fix

This Microsoft KB resolved this specific problem: http://support.microsoft.com/kb/961894

Disable Antivirus, Firewall and DEP:

1. Click Start, right-click My Computer, and then click Properties.
2. Click the Advanced tab, and then click Settings under the Startup and Recovery field.
3. In the System startup field, click Edit. The Boot.ini file opens in Notepad.
4. In Notepad, click Find on the Edit menu.
5. In the Find what box, type /noexecute, and then click Find Next.
6. In the Find dialog box, click Cancel.
7. Replace policy_level with AlwaysOff.

WARNING Make sure that you enter the text accurately. The Boot.ini file switch should now read:
/noexecute=AlwaysOff
8. In Notepad, click Save on the File menu.
9. Click OK two times.
10. Restart the computer.

More Information

As per L3's comments, socket mode is the right direction.
If you hit issue with the socket mode script, we will investigate it.

1) Please enable all the extended log options
2) Ensure the synamic values are correlated
3) Repaly the script, then save it as a .zip file, and upload it.


More Information

Please ask the customer to follow the below article and construct the redirection url. Let us know how it goes.

http://support.openview.hp.com/selfsolve/document/KM304916

More Information

In the snippet you provided, you didn't construct the web_url step
and instead you just included that captured url in lr_message.
Suggest to construct the url and update us with the script.
I doubt, we are able to completely resolve it with this option, but may help to move further

More Information

I think we are on the right track to add a new web_url at the beginning of the script,
because the script must pass a SSO login, then it can do the business process.

but there is still one thing we can not overcome:
How to submit the username and password to to SSO login page?
We know the username is: 501789650
For a normal web page, it should be a web_submit_data, with the username=501789650,
but in your script, I can not find the username with 501789650 anyway.
If we can not submit the username, the SSO login can not pass, that's the problem for now.
And I still can not find a solution for it.

More Information
I believe the application uses Single singon, and previously I remember we had problems to replay the Single Signon in web.
I'll confirm on this part.

1) Can you please replay the script using WinInet replay mode and see how it goes and get the script?
2) Do you had a requirement to load test with different users? ( like usera, userb, userc...)
3) Also, i can see the script has huge Java script activities, and i suspect if we can replay the complete Web http script.
Can you please record the script in Web(Click & Script) protocol (sockets mode and use GUI based) and replay?
please get the script with full logs.

More Information

1)     Could you replay the Web_Click & Script script with full logs?
i.e. enable all the extended log options, and replay it, then upload the script again.
We need the data in replay for the investigation.
2) Regarding the second question: Do you had a requirement to load test with different users? ( like usera, userb, userc...)
we are NOT asking about how many vusers will be lauched in the loadtest.
We would like to know if you will use different username to login to the Single Sign On.
In the webex, you showed us to login as user "501789650",
do you use this username only to login?
Do you need login with other username during a loadtest? such as: 501789651, 501789652, etc.

There is a long discussion so please visit below URL

https://support.openview.hp.com/casemanager/case/4001512190

1 comment: